4

I've updated my Visual Studio Code this morning, after doing update it restarted it self. I did not get any options(i.e. "Goto Definition", "Rename Symbol")when I right click on any variable, method, class name. After searching for a while I found that Opening View > Output might help me to know what's going on. and I found Omniserver is not running and below is the error which I got in Output window.

Starting OmniSharp server at 4/17/2019, 2:42:04 PM
    Target: d:\projects\Division\Division.sln

OmniSharp server started.
    Path: C:\Users\Unity3\.vscode\extensions\ms-vscode.csharp-1.19.0\.omnisharp\1.32.18\OmniSharp.exe
    PID: 7508

System.IO.FileNotFoundException: Could not load file or assembly 'netstandard, Version=2.0.0.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51' or one of its dependencies. The system cannot find the file specified.
File name: 'netstandard, Version=2.0.0.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51'
   at OmniSharp.Stdio.Driver.Program.<>c__DisplayClass0_1.<Main>b__1()
   at OmniSharp.HostHelpers.Start(Func`1 action)

=== Pre-bind state information ===
LOG: DisplayName = netstandard, Version=2.0.0.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51
 (Fully-specified)
LOG: Appbase = file:///C:/Users/Unity3/.vscode/extensions/ms-vscode.csharp-1.19.0/.omnisharp/1.32.18/
LOG: Initial PrivatePath = NULL
Calling assembly : Microsoft.Extensions.Logging.Abstractions, Version=2.1.1.0, Culture=neutral, PublicKeyToken=adb9793829ddae60.
===
LOG: This bind starts in default load context.
LOG: Using application configuration file: C:\Users\Unity3\.vscode\extensions\ms-vscode.csharp-1.19.0\.omnisharp\1.32.18\OmniSharp.exe.Config
LOG: Using host configuration file: 
LOG: Using machine configuration file from C:\Windows\Microsoft.NET\Framework64\v4.0.30319\config\machine.config.
LOG: Post-policy reference: netstandard, Version=2.0.0.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51
LOG: Attempting download of new URL file:///C:/Users/Unity3/.vscode/extensions/ms-vscode.csharp-1.19.0/.omnisharp/1.32.18/netstandard.DLL.
LOG: Attempting download of new URL file:///C:/Users/Unity3/.vscode/extensions/ms-vscode.csharp-1.19.0/.omnisharp/1.32.18/netstandard/netstandard.DLL.
LOG: Attempting download of new URL file:///C:/Users/Unity3/.vscode/extensions/ms-vscode.csharp-1.19.0/.omnisharp/1.32.18/netstandard.EXE.
LOG: Attempting download of new URL file:///C:/Users/Unity3/.vscode/extensions/ms-vscode.csharp-1.19.0/.omnisharp/1.32.18/netstandard/netstandard.EXE.

[ERROR] Error: OmniSharp server load timed out. Use the 'omnisharp.projectLoadTimeout' setting to override the default delay (one minute).

  • I can confirm that rolling back to v1.18.0 worked for me. Intellisense is working again. – Knub Apr 17 at 16:05
  • Yes, I confirm too, version 1.19 cannot show IntelliSense popup – phuongnd Apr 18 at 7:31
4

I had the same problem with Omnisharp v1.19.0 after updating VSCode. I ended up resolving it by rolling back the C# extension to an earlier version that worked for me (1.18.0). Right click the extension and select Install Another Version... Hope this helps!

  • There is already an issue to solve this problem: github.com/OmniSharp/omnisharp-vscode/issues/3004 Any news on the issue update the answer =) – Rafael Miceli Apr 17 at 19:34
  • It take one my working day to fix :( – phuongnd Apr 18 at 7:28
  • It could still my whole day but thankfully I had mono develop installed on my system so continued my there. – JE Games Apr 18 at 7:56
  • To anyone doing this, don't forget to set extensions.autoUpdate to false in VSCode preferences – rdixonbhw Apr 18 at 19:01
1

The rollback to 1.18.0 worked for me, but be sure to set the preference "extensions.autoUpdate" to false or it will just reinstall 1.19.0

  • Thanks for the advice. sorry I can't make 2 answer as right. – JE Games Apr 18 at 4:34
0

Latest OmniSharp requires .NET 4.7.2 to be installed, see https://github.com/OmniSharp/omnisharp-roslyn/blob/master/CHANGELOG.md#13214---2019-04-08

  • I'll keep that in mind – JE Games Apr 18 at 4:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.