0

I've tried to install graph-tool via anaconda for python 2.7:

conda install -c kristanarmstrong graph-tool

I got the following error:

UnsatisfiableError: The following specifications were found to be in conflict:
- graph-tool
Use "conda info <package>" to see the dependencies for each package.

Also I have tried: conda install -c jithinpr2 graph-tool conda install graph-tool conda remove graph-tool This hasn't worked as well. Previously this package hasn't been installed.

Are there any thoughts what is wrong in my approach?

1

First, I'd say be a little more cautious about where you source your code. Unless you know/trust the user, it can be risky to blindly install from someone's personal channel.

The kristanarmstrong only hosts a Python 3.4 version. The jithinpr2 is a Python 2.7 version, but it's also quite old, which could be the issue. Otherwise, the fact is that there are no reliable Conda channels that host the graph-tool package for win-64. There is an open thread on the repo discussing improving the installation.

I think the only option you really have here is to follow the Official Installation Instructions. It looks complicated, so the Docker option looks like it could be your quickest path forward if you just need to get it running and don't care so much about a Conda install.

The ideal solution is for someone to build feedstock for the tool on Conda Forge.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.